Google Classroom Roster Not Synced

If changes you make to your Google Classroom roster do not appear in your NGLSync roster after a few minutes, refresh your Google Classroom roster.

Cause

Your Google Classroom roster is out of sync with NGLSync and needs to be refreshed.

Resolution

Refresh your Google Classroom roster.

If your course page shows the error message This course is no longer receiving roster updates from Google Classroom:

  1. Click Refresh Roster next to the error message.

If your course page does not have an error message:

  1. Click Edit under Google Classroom Registration.
  2. Click Refresh Roster.
Your roster changes appear in NGLSync after a few minutes.